Elevated request latencies

Incident Report for Waitwhile

Resolved

This incident has been resolved.
Posted May 04, 2026 - 10:20 UTC

Monitoring

Latencies have returned to normal levels. We continue to monitor the service.
Posted Apr 27, 2026 - 08:45 UTC

Update

Latencies have improved but are still higher than usual. We continue to investigate the root cause.
Posted Apr 26, 2026 - 22:40 UTC

Update

We are continuing to investigate this issue.
Posted Apr 26, 2026 - 21:42 UTC

Investigating

We are currently experiencing poor response times for api.waitwhile.com for certain endpoints. We are investigating this issue and will report back as soon as we have more information.
Posted Apr 26, 2026 - 20:16 UTC
This incident affected: Waitwhile Services (Waitwhile Web Application, Waitwhile Public Pages, Waitwhile API).