Cloud Provider is experiencing latency issues

Incident Report for Waitwhile

Resolved

This incident has been resolved.
Posted Apr 20, 2023 - 18:56 UTC

Investigating

We are seeing increased latencies and and are investigating with our cloud provider. We will keep you updated as we know more.
Posted Apr 20, 2023 - 18:46 UTC