SMS Delivery Degradation in the US

Incident Report for Waitwhile

Resolved

This incident has been resolved.
Posted Nov 29, 2022 - 23:44 UTC

Monitoring

Our monitoring shows overall improvement in carrier-side traffic congestion, and we are observing instant SMS delivery at this time.

See more information on https://status.twilio.com/
Posted Nov 25, 2022 - 23:54 UTC

Identified

Due to increased traffic demand on mobile communication networks, we are expecting potential congestion for US carrier networks during the Black Friday and Cyber Monday period. Customers may experience intermittent SMS and MMS delivery delays.

See more information on https://status.twilio.com/
Posted Nov 25, 2022 - 16:59 UTC